CISCOルータを初めて触る / (1)初期化とIPアドレス設定

はじめに

CISCO ASA5505を知り合いから借りたので、設定の備忘録としてエントリします。

シリアルケーブルの準備

えっと、本体の初期設定を行うのに、USB⇔シリアル(RJ45)のケーブルを急遽購入しました。

FTDIチップ搭載のやつが有名で、安価なものも色々あるようです。

とりあえずAmazonで以下のものを購入。

FTDIのサイトから、VCPドライバを事前にWindows 10のPCにインストールしておきました。

VCP Drivers

上記のページから「Available as a setup executable」のリンクでexeファイルを落として実行するのが良いでしょう。

USB Serial PortはCOM5に割り当てられました。

ASA5505へシリアルポートから接続

先程のシリアルケーブルをASA5505の背面のConsoleポートに繋げて、Teratermから接続します。

接続パラメータはこんな感じ。

一回「Enter」を押すと、プロンプトが現れました。

ASA5505の初期化

先代オーナーからまずは真っ先に初期化するように言われていたので、実施します。

  • 「enable」で特権EXECモードに入る(パスワードが設定されていない場合はPassword:は空打ちで)
  • 「write erase」でスタートアップコンフィグを削除し、再起動後に初期化させる
    “Erase configuration in flash memory? [confirm]" にはEnter空打ちで
  • 「reload」で再起動を実行
    “Proceed with reload? [confirm]" にはEnter空打ちで

再起動後 “Pre-configure Firewall now through interactive prompts [yes]?" と聞かれるのでとりあえず「no」で終わらせました。(IOSコマンドをなるべく学びたいため)

「configure terminal」でグローバルコンフィギュレーションモードに移行します。(cont tでも代用可)

初回のみAnonymous error reportingを有効にするか聞かれますのでこれは「n」で先に進みました。

管理画面へのアクセス設定

LAN側の結線を行います。ASA5505背面の1番ポートに結線しました。

自宅のLAN環境は 192.168.1.0/24 のセグメントとなっており、今回は192.168.1.254を1番ポートに割り当てます。

グローバルコンフィギュレーションモードで以下のコマンドを入力します。

ciscoasa(config)# interface Vlan1
ciscoasa(config-if)# nameif internal
ciscoasa(config-if)# security-level 100
ciscoasa(config-if)# ip address 192.168.1.254 255.255.255.0
ciscoasa(config-if)# interface Ethernet 0/1
ciscoasa(config-if)# switchport mode access
ciscoasa(config-if)# switchport access vlan 1
ciscoasa(config-if)# no shutdown

「enable password (任意のパスワード)」コマンドでパスワードを設定します。

ASDMによるGUIな管理画面を利用するために以下のコマンドを入力します。

ciscoasa(config)# http server enable 443
ciscoasa(config)# http 192.168.1.0 255.255.255.0 internal

ここまでで、192.168.1.254に対してhttpsでアクセス可能になりましたので、任意のブラウザから「https://192.168.1.254」で繋げます。TLS証明書が無いのでブラウザにて警告が出ますが無視して先に進みます。

多分ASA5505のファームウェアが古いからですが、ブラウザによる管理画面が起動できなさそうです。
クライアントPCにJRE(32ビット版)を事前にインストールしてから、「Install ASDM Launcher」をクリックすると、dm-launcher.msi がダウンロードされるので、こちらをクライアントPCにインストールします。

その後、本来であればブラウザから自動的にこのJavaアプレットが実行されるみたいなのですが、私の環境ではうまく行かなかったので、「C:\Program Files (x86)\Cisco Systems\ASDM」内の「asdm-launcher.jar」を直接実行しました。

Device IP Addressには先程設定した「192.168.1.254」を、Usernameは空の状態で、Passwordには先程CLIから入力したパスワードを設定してOKを押します。

セキュリティ警告や、Windows Firewallの確認ダイアログが出ますが全て続行で。

無事ASDMの初期画面が表示されました。

おわりに

今回はここまでです。

ASA5505のCLIに、シリアルポート経由とASDM画面からも実行できそうなので、この環境をベースに今後以下の事を実施しようと思っています。

  • スタティックルート設定で既存のルータ経由でインターネットへoutbound設定
  • NTP設定
  • PCのdefault gatewayをASA5505経由での通信
  • Azure とのSite to Site VPN設定
  • IPv6の設定と有効利用

少しずつIOSコマンドを覚えて先に進めていきたいと思います。